Commands for Investigating AIX 5.2 Performance

From Wikistix

General

prtconf
lscfg -vp
topas
lparstat -i

Filesystems

df -kv
mount
lsfs -q
ioo -L

LVM, Disks and FC

lspv
lsvg -o | lsvg -i
lsvg -o | lsvg -li
lsvg -o | lsvg -pi
lsdev -Cc disk | while read a b; do echo $a; lsattr -El $a; done
lsdev | awk '/^(fcs|fscsi).*Available/{print $1}' | while read i; do echo $i; lsattr -El $i; done

Virtual Memory

vmstat -v
vmstat 5 5
lsps -a
ipcs -ma
ps auxw | sort -k 5nr | head -30
ps auxw | sort -k 6nr | head -30
vmo -L

Network

netstat -in
netstat -rn
no -L
ifconfig -a
lsdev | awk '/^ent.*Available/{print $0}'
lsdev | awk '/^ent.*Available/{print $1}' | while read i; do echo $i; lsattr -El $i; done

VIO Servers

All AIX-style commands should run fine from the oem_setup_env prompt.

lsmap -all